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Part 1: Introduction to STATA & its components 





Type command here to execute

Version number

All 

previously 

executed 

commands 

show here

List of all 

variables in 

data

Type of 

variable, total 

obs., data name 

etc.

Results from 

executing 

commands

cToolbar



Click on File

Load data into the working 

directory from here



Click on Edit→ Preferences

Here you can change the 

appearance of your interface, its 

color etc



Click on Data

View your data, make changes 

in variables, work with variables



Click on Graphics

Create various kinds of graphs 

and charts



Click on Statistics

Do all kinds of analysis like find 

mean, SD, linear regression, 

etc.



Click on Window

Open, view, hide 

various windows 

in STATA



Click on Help

Take help on 

command, syntax, 

etc.



Open

a file

Save the 

data in 

STATA 

format- dta

Create a 

new log 

file

View the 

graph 

created 

by you

Create a 

new Do 

file

Data 

editor-

view 

and edit 

data

Data 

browser-

only 

view 

data
View 

variable list 

and their 

properties

Print 

results



Types of files generated by STATA



Step 1: Load data into STATA



1. Using Example data sets 
already stored in STATA

▪ Click on File→
Example Datasets



▪ Click on Example Datasets 
installed with STATA



▪ Click on use to load data



Data is loaded into STATA



In the command window 
type:

clear all

Press enter

Erase the existing data 



2. Import data in non-STATA format; eg- excel file

Click on File→ Import→ Excel 

spreadsheet



Click on Browse
Select the excel file 

and click Open



Select Import 

first row as 

variable names

Click Ok



Data is loaded



3. Use a STATA data file- dta format

Click on Open

Select folder and choose dta file



Exercise: Open auto.dta file from Example datasets
Use this file for now



Step 2: Viewing data



▪ Click on Data 
browser



Step 3:Saving this data as dta file



1. Click on 

File→ Save as

2. Give the 

data a name:  

example_data

3. The file is saved, and the 

result is displayed in Results 

window



Step 3:Saving this data as excel file



1. Click on Export→
Data to Excel 
spreadsheet

2. Click on Save as..



3. Give your excel 
file a name-
example_data

4. Check the box of above 2 
options. Then click OK

5. Data is saved in xls format



Part 2: Understanding your data



Types of data

Non-numeric data
E.g.- name of a person or 

place

Numeric data
E.g.- age, income, years of 

schooling

Stored as String data

Format- %str

Pure numeric data
Format- long, byte, 

int, float, double 

Continuous – age, 

income

Discreet/categorical with 

many categories- no. of 

college classes in a day

Numeric data 

with labels
Format- long, byte, 

int, float, double 

Discreet/categorical with many 

categories- subjects taken by a 

student: 1=Eng, 2= eco, 3= 

math 

Dummy with only 2 categories: 

gender: 0=female, 1=male



Name of variables

Pure numeric data Numeric data with 
label attached

Obser-
vation
no.

String data (non-
numeric)

Selected cell value is 
shown at top

sysuse auto.dta



View data

1. Browse

browse→view entire data

br→in short, view entire data

br make price mpg → view only mentioned variables

2. Count no. of observations

count

Click on data browser



Describe data

3. Obtain the list of all variable names, their type, their label, data name

describe

des

d

d make price mpg



Storage type and display format

Storage type:

▪ str18 → string variable with 18 characters allowed

▪ int, float, byte → numeric variables

Display format:

▪ %-18s → string variable, 18 characteristics, left-justified

▪ %6.1f → fixed format numeric variable, 6 characters, 1 decimal, right 
justified

▪ %8.0g → general format numeric variable, 8 characters, no decimal, right 
justified



Summarize data

4. Summarize data to get mean, SD, etc

sum sum make price mpg



Summarize in detail

5. Detailed summary of a variable
sum mpg, d

Compare it with sum mpg



See data in Results window

6. list command

list →view entire data

list price →view all observations of price

list in 1/10 →view only 1st 10 observations for all variables

list price mpg in 1/10 →view only 1st obs. of price and mpg



Sort variables

6. sort command

sort make→ sort alphabetically over make

sort price →sort from smallest to largest over price

sort foreign make →sort by foreign first, then in each category of 
foreign, sort alphabetically by make

Go to data browser to see how data gets sorted from above



Change order of variables in dataset

7. order command

order make foreign→ after make, put foreign

order foreign, first →bring foreign in the beginning

order price, last → push price to the last

order price, a(foreign) → put price after foreign

order price, b(foreign) → bring price before foreign

Go to data browser to see how variables get ordered 



Error in STATA

Instructions to 

remove error

Best way to get rid 

of error:
help sort
help command



Tabulate variables

7. tabulate command

a)One-way tabulate

tab rep78 tab rep78, sort

Frequency 

distribution of a var

Frequency sorted 

from high to low



Tabulate variables

7. tabulate command

a)One-way tabulate

tab foreign tab foreign, nolabel



Tabulate variables

7. tabulate command

b) Two-way tabulate

tab rep78 foreign tab rep78 foreign, nolabel



Tabulate variables

7. tabulate command

b) Two-way tabulate- options

tab rep78 foreign, col tab rep78 foreign, row



Tabulate variables

7. tabulate command

b) Two-way tabulate- options

tab rep78 foreign, col nofreq



Tabulate variables

8. table command

a) one-way table

table rep78 table rep78, row



Tabulate variables

8. table command

b) two-way table
table rep78 foreign table rep78 foreign, row

table rep78 foreign, row col



Tabulate variables

8. table command

c) Three-way table
table headroom rep78 foreign



Tabulate variables

8. table command

c) Table to get some statistics other than frequency
table foreign, c(mean headroom mean price)

table rep78 foreign, c(mean price)



Combine tabulate and summarize

9. tab, sum() command

tab foreign, sum(price)



Show results by type

10. bysort command

bysort foreign: sum(price)

bysort foreign: tab rep78

Exercise: Try bysort with count and tab,sum



If command

11. Can be combined with all commands to execute a command based on a condition
command if (condition), options

br if price==6486
br if price>2000
br if price<=2000
br if make==“Plym. Sapporo”

sum mpg if foreign==0
tab foreign if price>2000, sort
tab foreign rep78 if price>2000, col

Combining conditions:
sum mpg if (foreign==0) & (price>2000)→ summarizes mpg taking only those 
observations where car is domestic AND price is more than 2000
sum mpg if (foreign==0) | (gear_ratio==2.5)→ summarizes mpg taking only 
those observations where EITHER car is domestic OR its gear ratio is 2.5 OR 
BOTH.



Log file- saving results

▪ Log file saves all the output from results window in a file.

▪ Format- SMCL file

▪ One can open it later to view all work done before.

log using “C:\path\log file.smcl”, replace

(commands)

log close

Show creating log file using Tool bar



Log file- saving results

clear all

log using “C:\path\log file.smcl”, replace

sysuse auto.dta

sum mpg

log close

Now open the log file to view all history of work.



Result-



Do file- saving commands

▪ Do file saves all the commands

▪ Format- .do

▪ One can use it to rerun all/subset of commands

▪ Good practice

▪ Use Toolbar to open a new Do-file



Write commands in Do file



Run commands from Do file

Select a line and press the 

icon in circle

OR

Select a line, then CTRL+ D



Save a Do file

Click File→ Save as..

Give name to DO file

Press Save



Save a Do file

Click File→ Save as..

Give name to DO file

Press Save



Insert comments in Do file

▪ Comments are those rows that 
you don’t want to execute

▪ They are used to insert any 
note, specific comment, or skip 
a particular line of code

▪ Insert using 

1. /* */→ anything that comes 
b/w /* and */ will be not 
executed

2. * →a particular line won’t be 
executed

3. //→ same as above



Part 3: Data transformation



The display command

di expression

▪ Helps to simply display something

▪ Mostly used to perform quick calculations

di 2+2

di (25*50)/20

di “mpg”

di “Sum of 1 and 2=” 1+2

help di



Changing attributes of existing variables
but keeping original data intact

1. Change name of variable

rename oldname newname
rename mpg mileage

2. Change variable label

label var varname “write label here”
label var price “Price in dollars”

3. Change value labels

label define car_type 0 “Domestic car” 1 “Foreign car”
label values foreign car_type

4. View and save existing labels in directory

label list
label save using "C:\Users\shweta.gupta\Desktop\stata15\STATA 15 
files\labels.do", replace

Don’t use long names

Only 32 characters allowed

No spaces

New name



Changing attributes of existing variables
but keeping original data intact

5. Reduce decimals in numeric variable

format gear_ratio %6.1f

6. Reduce no. of characters in string

format make %-10s

7. Change justification

format make %18s →right-justified

format price %-8.0gc →left-justified

format mpg %~8.0g →centre-justified

This does not 

change data, only 

appearance in 

browser changes



Changing values of existing variables
this changes the data values

1. Replace values

replace price=5000 →replaces price by 5000 in all observations

replace price=5000 if price==5500 → replace price by 5000 only when 
price=5500

replace mileage=30 if foreign==0 → replace mpg by 30 in those obs. where 
foreign=0 or Domestic

replace mpg=30 if make==“Ford Fiesta” → replace mpg by 30 in those obs. 
Where car type (make) is Ford Fiesta

replace price=price+1000 if make=!“Ford Fiesta”

replace price

Replace trunk= mileage+125



Changing values of existing variables
this changes the data values

2. Recode values

recode 0=1 1=2

tab foreign, nol

recode rep78 1=400

tab rep78

▪ This replaces in foreign, all values that were 0 before to 1, 

and all values that were 1 before to 2

▪ Useful when categorical data



Generating new variables

gen newvarname= expression

1. Generating using math operations

gen newvar=2000

gen mpg2= mpg+2

gen mpg78= mpg+rep78

gen weight2= weight-trunk

gen length2= length*2

gen headroom2= headroom/2

gen headroom3= headroom/rep78

gen pricesq= price^2

gen priceroot= price^(1/2)

gen lnprice= ln(price)
gen logprice= log(price)
gen erep78= exp(rep78) →erep78



Generating new variables

2. Generating using string variables

gen make2= “Type”

gen make3= make2 + “:” + make

Note:

▪ string and numeric cant be combined

▪ Numeric can be combined with numeric only

▪ String can be combined with string only

▪ In string, only the addition of strings is allowed



Generating new variables

3. Generating using cond option

Helps create categorical variables

gen newvar= cond(condition,value of newvarif condition is 
TRUE,value of newvar if cond is FALSE)

gen high_price= cond(price>3000,1,2)

newvar→ high_price

Condition→ price>3000

Value of high_price if price>3000→ 1

Value of high_price if price<=3000→2



Condition command

*new var= high_price

*high_price=1000 if price>1000

*high_price=500 if pricr<=1000

gen high_price= 1000 if price>1000

replace high_price=500 if price<=1000

gen high_price= cond(price>1000,1000,500)

gen high_price=cond(price<=1000,500,1000)



Generating new variables

4. Generating dummy variables

Dummy variable takes value 0 or 1

Use gen, replace, if

gen newvarname=1 if condition=TRUE

replace newvarname=0 if condition=FALSE

gen high_price2= 1 if price>3000

replace high_price2=0 if price<=3000

Use the gen, cond option to create dummy



Generating new variables

5. Generating dummy variables from discreet data

tab rep78,gen(repdummy) →gives dummy variable for each category of rep78

repdummy1  =1 if rep78 equals 1

=0 otherwise that is, rep78 =2/3/4/5

repdummy2  =1 if rep78 equals 2

=0 otherwise

repdummy3  =1 if rep78 equals 3

=0 otherwise

repdummy4  =1 if rep78 equals 4

=0 otherwise

repdummy5  =1 if rep78 equals 5

=0 otherwise



Generating new variables

6. Generating specialized variables- egen command

egen newvarname= expression

egen meanrep= mean(rep78) →generates meanrep = mean of rep78 in 
all observations

egen medrep= median(rep78) →generates medrep = median of rep78 
in all observations

egen modrep= mode(rep78) →generates modrep = mode of rep78 in all 
observations

min, max, range,count, total

Do help egen to show options



Generating new variables

7. egen to add variables

Adding variables:

egen reptr= rowtotal(rep78 trunk) →generates reptr = sum of 
rep78 and trunk for each observation

Compare this with gen:

gen reptr2= rep78 + trunk

reptr2=reptr

gen replaces reptr2 by missing (.) if rep78 or trunk is missing in any obs.

egen treats missing as 0 while calculating the sum



Generating new variables

8. Create unique ID

gen newvar= _n → creates ID variable with values 1,2,3…

gen id= _n

bysort rep78: gen id2= _n

9. Create unique ID by groups

egen newvar= group(grouping variable)

egen id3= group(rep78) 

Headroom has 8 classes, so id2 takes the value 1,2,3,4,5,6,7,8 



Generating new variables

10. Create unique ID within groups

bysort group-varname: gen newvar= _n → creates ID variable with 
values 1,2,3…within each subgroup of group-varname

bysort rep78: gen newid= _n → creates newid variable=1,2,3… 
within each category of rep78 (5 categories=1,2,3,4,5)



Generating new variables

11. Get total number of observation

gen newvar= _N → creates a new variable = total no. of observations in 
data

gen idtot= _N → takes the value 74 in our data

12. No of observations per sub-group

bysort rep78: gen sub_idtot= _N → creates new variable= total obs. 
per category in rep78 (5 categories=1,2,3,4,5)

br rep78 newid sub_idtot



Remove variables or observations

▪ Keep/drop variables and observations

keep varlist
keep mpg price
keep if price==2000
keep price* → keeps all variables with price in their name (price, pricesq)

keep t* → keeps all variables starting with t

keep *t → keeps all variables ending with t

keep *ea* → keeps only those vars which have ea in their name

drop varlist
drop mpg
drop if price==2000

▪ Be careful while dropping

▪ Data can’t be restored once you drop

▪ Best practice- save the data before working on it



Changing variable type

▪ Convert numeric variable to string
tostring oldvarname, gen(newvarname)
tostring price, gen(price2)

tostring varname(s), replace 
tostring price mpg, replace

▪ Convert string to numeric

This is possible only when there are numbers stored as string
destring oldvarname, gen(newvarname)
destring price2, gen(price3)

destring oldvarname, replace
destring price2, replace



Installing commands in STATA

ssc install commandname

findit commandname

help commandname



Part 4: Data visualization



scatterplot

Two variable plot-

scatter y x

scatter mpg weight

Multiple variables-
scatter y1 y2 x
scatter mpg turn weight



Line graphs

Two variable plot-

twoway line y x, sort

twoway line mpg weight

Multiple variables-
twoway line y1 y2 x, sort
twoway line mpg turn weight, sort



Scatter+Line graphs

Two variable plot-

twoway connected y x, sort

twoway connected mpg weight

Multiple variables-
twoway connected y1 y2 x, sort
twoway connected mpg turn weight, sort



Histogram 

▪ Use the toolbar for best results

histogram x, options

histogram headroom

hist head, freq

hist head, percent



Bar graph 

graph bar, over(x)

graph bar, over(head)

graph bar (count), over(x)

graph bar (count),over(head)

Percent by 

default



Bar graph 

graph bar (mean) y, over(x)

graph bar (mean) price, over(rep78)

tab rep78, sum(price)

graph bar (mean) y1 y2 , over(x)

graph bar (mean) price weight, over(rep78)

table rep78, c(mean price mean weight)



Density curve 

kdensity x

kdensity price

▪ Gives the distribution of the 
variable-
oarea on y-axis
oRange of values of the 

variable on x-axis
NOTE: Area under the curve==1 
ALWAYS

▪ Can plot only 1 variable at a time, 
but can be combined using 
twoway



Density curve 

kdensity x, normal

kdensity price, normal



Graph attributes

1. Labelling axis-

scatter mpg weight, ytitle(Mileage of car) xtitle(Weight of car)

2. Title, subtitle of main graph-

scatter mpg weight, title(Scatter Plot)

3. Background color 

scatter mpg weight, graphregion(color(green))

4. Colour scheme of entire graph

scatter mpg weight, scheme(economist)

5. Scale of graph

scatter mpg weight, xsize(10) ysize(10)



Graph attributes

6. Assign name to graph in directory

scatter mpg weight, name(scatter1, replace)

scatter mpg turn weight, name(scatter2, replace)



Graph attributes

6. Saving a graph- editable in STATA format

graph save using “C:\path\scatterplot.gph”, replace

▪ Show saving directly using toolbar

7. Exporting a graph- png/pdf/jpg

graph export using using “C:\path\scatterplot.png”, replace

▪ Show saving using toolbar



Graph using IF condition

scatter mpg weight if price>2000

▪ Plots pairs of mpg and weight for which price>2000

scatter mpg weight if foreign==1

▪ Plots pairs of mpg and weight for which foreign=1



Plotting multiple graphs together

▪ Overlaying graphs

scatter mpg weight || scatter turn weight

tw (scatter mpg weight ) (scatter turn weight)

scatter mpg turn weight

▪ Using if condition

scatter mpg weight if foreign==0|| scatter mpg weight if foreign==1

▪ Using by in the graph command 

scatter mpg weight, by(foreign)



Plotting multiple graphs together

▪ Graph combine

scatter mpg weight if foreign==0, name(scatter1, replace)

scatter mpg weight if foreign==1, name(scatter2, replace)

graph combine scatter1 scatter2

graph combine scatter1 scatter2, ycommon



Plotting graphs conditioned on data

▪ Combining histogram and frequency distribution

▪ Generate a variable, say total, with frequency for each class of x variable

bysort headroom: gen headtotal= _N

tw histogram headroom, frequency||connected headtotal headroom



Other graphs

▪ Piechart- graph pie..

▪ Dot chart- graph dot..

▪ Box plots- graph box x



What is a `good’ graph?

▪ Easy to understand (not too many lines or points, not clumsy)

▪ Should deliver the message it is supposed to give

▪ Always label axes

▪ Always give a key when plotting multiple variables

▪ Always give title

▪ Don’t plot too many variables in one graph as much as possible



Question

▪ Can you plot a graph with 1 or more string variables?



Generating a variable with specific distributions

11. Random variable with normal distribution

gen newvar= rnormal(m,s) → creates a new variable that follows normal 
distribution with mean=m, SD=s 

newvar ~N(m,s)

Normality is a law of large samples

a) When you don’t have any data in your directory

clear all

set obs 10

set seed 15678

gen normalvar= rnormal(4,10)

sum normalvar

kdensity normalvar

Write this in a Do file.

Observe how summary and kdensity

changes when N=10, 100, 1000, 10000, 

10000: Dist. Becomes closer to bell curve 

with mean=4, SD=10.



Generating a variable with specific distributions

11. Random variable with normal distribution

b) If some data already exists in your 
directory

gen normalvar= rnormal(4,10)

sum normalvar

kdensity normalvar

Setting seed helps to get the same set of 
random numbers every time you run the code



Generating a variable with specific distributions

12. Random variable with standard normal distribution

gen newvar= rnormal(0,1) 

newvar ~Z(m,s) 

gen newvar= rnormal()



Generating a variable with specific distributions

12. Uniform distribution

gen newvar= runiform(a,b) 

where, 
a= minimum and b= maximum
Mean=(a+b)/2
Variance=(b-a)2/12

clear all

set obs 10000

set seed 15678

gen uniformvar= runiform(4,10)

sum uniformvar

kdensity uniformvar

Now find mean and variance from sum and check

help random



Working with multiple datasets

▪ Merge 2 data files

▪ Append 2 or more data files



Advanced: Changing layout of data

▪ Reshape

▪ Wide to long

▪ Long to wide


